Project

General

Profile

Bug #18

core dump after run clish without params (assert in release)

Added by Anonymous over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
High
Assignee:
Target version:
Start date:
10/02/2015
Due date:
% Done:

0%


Description

Os: Ubuntu 14.04
platform: x64

Why not disabled assert in release?

LD_LIBRARY_PATH=/usr/local/lib/ clish
clish: clish/shell/shell_startup.c:16: clish_shell_startup: Assertion `this->startup' failed.
<path>/klish-1.7.1/clish/shell/shell_startup.c:16
int clish_shell_startup(clish_shell_t *this) {
const char *banner;
clish_context_t context;
int res = 0;

assert(this->startup);

stack:
#0 0x00007ffff7623cc9 in GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007ffff76270d8 in __GI_abort () at abort.c:89
#2 0x00007ffff761cb86 in __assert_fail_base (fmt=0x7ffff776d830 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7ffff7bd1cad "this->startup",
file=file@entry=0x7ffff7bd1c91 "clish/shell/shell_startup.c", line=line@entry=16, function=function@entry=0x7ffff7bd1d80 "clish_shell_startup") at assert.c:92
#3 0x00007ffff761cc32 in __GI
_assert_fail (assertion=0x7ffff7bd1cad "this->startup", file=0x7ffff7bd1c91 "clish/shell/shell_startup.c", line=16,
function=0x7ffff7bd1d80 "clish_shell_startup") at assert.c:101
#4 0x00007ffff7bcb62f in clish_shell_startup () from /usr/local/lib/libclish.so.0
#5 0x0000000000401f4b in ?? ()
#6 0x00007ffff760eec5 in __libc_start_main (main=0x401980, argc=1, argv=0x7fffffffdec8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>,
stack_end=0x7fffffffdeb8) at libc-start.c:287

History

#1 Updated by Serj Kalichev over 2 years ago

  • Status changed from New to Rejected

The cause is absence of XML configs and so the absence of STARTUP tag. The klish search for the XML files in /etc/clish and in ~/.clish dirs by default. You have not XML files in these locations.

Also available in: Atom PDF