Project

General

Profile

Bug #14

xml parse error

Added by Anonymous over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
High
Assignee:
Target version:
-
Start date:
06/27/2015
Due date:
% Done:

0%

Estimated time:

Description

Hi

Thank you so much for this great tool.
i have a problem with klish 2.0.4 when i add action like that :

<ACTION>
exec /bin/blah > /dev/null
</ACTION>

klish show me an error for xml parse and exiting.
i configured klish with libxml2 and all library and directory is correct.
without "<" or ">" character every thing is good.

thanks
z30

History

#1 Updated by Serj Kalichev over 3 years ago

  • Status changed from New to Rejected

Hi

It's not a bug. It's a feature of XML
The < and > symbols are the begining of XML tag and the ending of XML tag (for example "<COMMAND>"). So the engine can't differ shell redirect and tag beginning/ending. The "<" must be used for "<" and ">" for ">".

#2 Updated by Serj Kalichev over 3 years ago

:) The html has convert my chars within answer.
I mean "& l t ;" (without spaces) for "<" and "& g t ;" (remove all spaces) for ">".

Also available in: Atom PDF